Справка по MetaTrader 4
Управление графиком

Управление графиком

Графики позволяют анализировать динамику цен на рынке и используются для графического анализа, построения различных индикаторов и линейных инструментов. Графики являются исключительно ценным инструментом для анализа финансовых рынков, поэтому им уделяется большое внимание. Управление графиком — это:

  • Смена вида
    График финансового инструмента может быть трех видов:
  • Сохранение
    Клиентский терминал позволяет сохранять исторические данные активного графика в виде текстового файла в форматах "CSV", "PRN" и "HTM".
    Чтобы сохранить их таким образом, нужно выполнить команду меню "Файл— Сохранить как" либо нажать на клавиши-акселераторы Ctrl + S. Кроме того, можно сохранять график в виде рисунка формата BMP или GIF. Для этого надо выполнить команду меню "Файл—Сохранить как рисунок". Те же действия выполняются одноименной командой контекстного меню графика.
  • Печать
    Для цветной печати изображения активного графика нужно в настройках графика установить флажок "Цветная печать", затем выполнить команду меню "Файл — Печать...", одноименную команду контекстного меню графика, нажать на кнопку Печать графика панели инструментов "Стандартная" или на клавиши-акселераторов Ctrl+P. Если флажок "Цветная печать" снят или отсутствует цветной принтер, то график печатается в черно-белом виде.
  • Полный экран
    Выполнение команды меню "Вид — Полный экран" или нажатие на клавишу F11 приводит к переходу в полноэкранный режим. На экране, кроме окон графиков, остается главное меню и панель переключения графиков. Вернуться к исходному режиму можно, выполнив ту же команду.
  • Присоединение программ MQL4
    Перед началом выполнения программы MQL4 ее нужно присоединить к графику. Для этого нужно в окне "Навигатор" выбрать требуемую MQL4-программу и дважды щелкнуть на ней или выполнить команду контекстного меню "Присоединить к графику". Также можно использовать технологию "Drag'n'Drop".
  • Работа с индикаторами
    Индикатором называется математическое преобразование цены и/или объемов финансового инструмента для прогнозирования будущих изменений цен. На основе сигналов технических индикаторов принимаются решения относительно того, как и когда открывать или закрывать позицию. Индикаторы можно наложить на график при помощи команд меню "Вставка —Индикаторы" либо команд подменю управления индикаторами, которое открывается кнопкой Индикаторы панели инструментов "Графики". Технология "Drag'n'Drop" также позволяет накладывать индикаторы из окна "Навигатор" на любое открытое окно. Список наложенных на график индикаторов можно просмотреть в "Окне Данных", выполнив команду меню "Графики — Список индикаторов", одноименную команду контекстного меню графика, либо нажав клавиши-акселераторы Ctrl+I.
    Более детальная информация о работе с техническими индикаторами приводится в одноименном разделе.
  • Работа с объектами
    Для проведения анализа на график можно также накладывать различные графические объекты. Для этого нужно воспользоваться командами меню "Вставка" либо кнопками панели инструментов "Графические инструменты". В меню сгруппированы линейные инструменты, геометрические фигуры, значки и текст.
    Более детальная информация находится в разделе "Графические объекты".
  • Смена периода
    Клиентский терминал поддерживает девять различных периодов данных, от минутных до месячных. Большое количество периодов графиков необходимо для проведения анализа рынков посредством технических индикаторов и линейных инструментов.
    Выбрать требуемый период графика можно при помощи панели "Период", кнопки Период графика панели "Графики", меню "Графики — Период" либо выполнением одноименной команды контекстного меню графика.
  • Масштабирование
    Графики можно масштабировать по горизонтальной оси и тем самым увеличивать или уменьшать количество одновременно отображаемых на экране баров.
    Для этого предназначены кнопки Увеличить масштаб / Уменьшить масштаб панели "Графики", клавиши "+" / "-", команды "Увеличение"/"Уменьшение" контекстного меню графика и меню "Графики".
    Для уменьшения масштаба по вертикальной оси также можно захватить левой кнопкой мыши произвольную точку оси и сдвинуть ее вниз. Двойной щелчок мыши на вертикальной оси или нажатие клавиши "5" на дополнительной цифровой клавиатуре восстанавливает масштаб.
    Кроме того, в окне свойств графика при помощи опции "Фиксировать масштаб" можно задать точный масштаб, определив верхнюю и нижнюю границы. Опция "Фиксировать масштаб 1:1" того же окна позволяет установить масштаб "один к одному", то есть, один пипс вертикальной оси будет соответствовать одному бару на горизонтальной.
  • Прокрутка, автопрокрутка и сдвиг графика
    Прокрутка — это смещение ценовых данных на графике вправо/влево, выполняемое курсорными клавишами клавиатуры. Кроме того, прокручивать график можно при помощи клавиш F12 (режим "Шаг за шагом" — смещение графика на один бар влево) и Shift+F12 (смещение графика на один бар вправо), а также при помощи мыши: удерживая левую кнопку мыши на любой точке графика, необходимо перемещать курсор вправо/влево. Также при помощи строки быстрой навигации можно отобразить необходимую область графика, указав конкретные дату и время. В случае сдвига графика в область, где отсутствуют ценовые данные, произойдет автоматическая загрузка недостающих баров.
    Если зафиксирован масштаб графика, его можно также прокручивать по вертикали. Для этого необходимо удерживая бегунок на вертикальной шкале перемещать мышь вверх/вниз. Чтобы вернуть график в пределы видимости, необходимо нажать клавишу "5" на дополнительной цифровой клавиатуре либо дважды кликнуть мышью в области ценовой шкалы графика.
    Автопрокрутка предназначена для того, чтобы всегда перед глазами иметь последние бары. Если эта опция включена, с приходом новой котировки график автоматически перемещается в конец. Включить данную функцию можно кнопкой Автопрокрутка панели "Графики" и командой меню "Графики — Автопрокрутка".
    Опция "Сдвиг графика" отодвигает последний бар от правого края экрана до метки сдвига графика. Метку сдвига графика (серый треугольник в верхней части окна) можно перемещать мышкой по горизонтали в пределах 10-50% размера окна. Сдвиг графика включается кнопкой Сдвиг графика панели "Графики" и командой меню "Графики — Сдвиг графика".
  • Позиционирование графика
    Обычно точка привязки графика располагается в левой части окна. К ней привязывается бар с конкретным временем, который можно переместить при помощи прокрутки или строки быстрой навигации. При смене таймфрейма производится попытка рассчитать новый бар привязки, соответствующий бару на предыдущем периоде. То есть, с левого края окна графика будет отображаться ближайший к заданной точке временной промежуток. Точку привязки (серый треугольник на нижней границе графика) можно перемещать в пределах окна графика при помощи мыши. Он появляется только в случае, если отключена "Автопрокрутка". Этот механизм удобен при анализе определенного временного промежутка на разных таймфреймах.

Внимание: позиционирование не работает, если включена опция "Автопрокрутка".

  • Работа с шаблонами
    Шаблоны представляют собой запись характеристик окна графика. В шаблоне сохраняются: вид графика, период, масштаб, все настройки линейных инструментов, технических и пользовательских индикаторов, а также экспертов. Шаблоны позволяют легко и быстро приводить множество различных графиков к единому виду.
    Меню управления шаблонами можно вызвать командой меню "Графики — Шаблон", одноименной командой контекстного меню графика и кнопкой Шаблоны графиков панели "Графики". Команда меню "Сохранить шаблон..." позволяет сохранить новый шаблон, а "Удалить шаблон" — удалить ранее созданный.
    Более детальная информация находится в разделе "Шаблоны и профили".
  • Работа с профилями
    Концепция профилей предлагает удобный способ работы с группами графиков. Когда открывается профиль, каждый график со всеми настройками располагается точно в том же месте, где он был при сохранении профиля.
    Меню управления профилями можно открыть командой меню "Файл — Профили", нажав кнопку Профили панели инструментов "Стандартная" либо щелкнув мышью в окошке статусной строки с именем текущего профиля.
    Более детальная информация находится в разделе "Шаблоны и профили".
  • Обновление данных
    К обновлению данных прибегают в случае возникновения ошибок или "дыр" на ценовом графике. Чтобы обновить ценовые данные, необходимо выполнить команду меню "Графики — Обновление" или одноименную команду контекстного меню графика. При выполнении всех этих действий происходит автоматическая загрузка с сервера недостающих баров и их прорисовка на графике.

Работа мышью

Управление графиком непосредственно мышью производится следующим образом:

  • нажатие левой кнопки мыши в любой точке окна графика и удержание с последующим горизонтальным перемещением курсора приводят к прокрутке графика;
  • нажатие левой кнопки мыши на вертикальной шкале графика и удержание с последующим вертикальным перемещением курсора приводят к изменению масштаба графика по вертикали, двойной щелчок мыши на вертикальной шкале восстанавливает масштаб;
  • нажатие левой кнопки мыши на горизонтальной шкале графика (кроме области строки быстрой навигации) и удержание с последующим горизонтальным перемещением курсора приводят к изменению масштаба графика;
  • нажатие правой кнопки мыши в любой точке окна графика вызывает контекстное меню графика (описано ниже);
  • двойной щелчок левой кнопки мыши на элементах технических индикаторов (линии, символы, столбцы гистограмм и так далее) вызывает окно настройки соответствующего индикатора;
  • щелчок правой кнопкой мыши на элементах технического индикатора вызывает контекстное меню индикатора;
  • одинарный либо двойной, в зависимости от настройки терминала, щелчок левой кнопкой мыши на объекте (линейный инструмент, текст или значок) выделяет объект;
  • нажатие левой кнопки мыши на выделенном объекте и удержание с последующим перемещением позволяет перемещать выделенный объект;
  • Ctrl + нажатие левой кнопки мыши на выделенной трендовой линии с последующим перемещением позволяет нарисовать параллельную трендовую линию (создать канал);
  • щелчок средней кнопки мыши в окне графика переводит курсор в режим "перекрестье";
  • нажатие правой кнопки мыши на выделенном объекте открывает его контекстное меню;
  • установка курсора на цене закрытия бара либо на элементе объекта или индикатора вызывает подсказку.

Управление графиком при помощи команд контекстного меню

Часть команд контекстного меню предназначена для управления графиком:

  • Советники — подменю управления советниками. Советником (экспертом) называется MQL4-программа, выполняющаяся с каждым новым тиком и позволяющая автоматизировать аналитическую и торговую деятельности. В подменю управления советниками сгруппированы команды управления наложенным на график экспертом. При помощи этого подменю можно изменить свойства советника, удалить его или приступить к тестированию.
    Более детальная информация находится в разделе "Советники".
  • Удалить скрипт — удалить исполняемый скрипт. Скриптом называется программа, написанная на языке MetaQuotes Language 4 (MQL4) и предназначенная для одноразового выполнения каких-либо действий.
  • Список индикаторов — окно управления техническими индикаторами, присоединенными к окну графика. Техническим индикатором называется математическое преобразование цены и/или объемов финансового инструмента для прогнозирования будущих изменений цен. На основе сигналов технических индикаторов принимаются решения относительно того, как и когда открывать или закрывать позицию.
  • Список объектов — окно управления графическими объектами. Графическими в терминале называются объекты, накладываемые на график вручную. Они предназначены для аналитических целей.
  • Период — подменю управления периодом графика.
    Периодом графика можно также управлять при помощи одноименных команд меню "Графики" и панели инструментов.
  • Шаблон — подменю управления шаблонами. Шаблоном называется набор настроек окна графика, который можно применить для других графиков.
    Подменю управления шаблонами можно также вызвать при помощи одноименной команды меню "Графики".
  • Обновление — обновить исторические данные. При этом произойдет загрузка всех недостающих в пределах имеющейся истории и новых данных.
    Это же действие можно выполнить одноименной командой меню "Графики".
  • Авторазмер — установить высоту всех окон индикаторов по умолчанию.
    Это же действие можно выполнить нажатием клавиш-акселераторов Ctrl+A.
  • Сетка — показать/скрыть сетку.
    Это же действие можно выполнить одноименной командой меню "Графики" и нажатием клавиш-акселераторов Ctrl+G.
  • Объемы — показать/скрыть график объемов.
    Те же действия можно выполнить одноименной командой меню "Графики" и нажатием клавиш-акселераторов Ctrl+L.
  • Увеличение — увеличить масштаб графика по горизонтали на один шаг.
    Масштаб можно также увеличить при помощи одноименной команды меню "Графики", клавиши "+" или кнопки Zoom In панели инструментов "Графики".
  • Уменьшение — уменьшить масштаб графика на один шаг.
    Масштаб можно также уменьшить при помощи одноименной команды меню "Графики", клавиши "-" или кнопки Zoom Out панели инструментов "Графики".
  • Удалить окно индикатора — удалить окно индикатора. Некоторые индикаторы строятся в специальных подокнах с собственной шкалой. Эта команда позволяет удалить такое подокно.
    Более детальная информация по работе с техническими индикаторами приводится в соответствующем разделе.
  • Сохранить как рисунок — сохранить график в виде рисунка (формат GIF или BMP).
    Это же действие можно выполнить командой меню "Файл — Сохранить как рисунок".
  • Предварительный просмотр — предварительный просмотр образа графика перед печатью.
    Это же действие можно выполнить командой меню "Файл — Предварительный просмотр" или кнопкой предварительный просмотр панели инструментов "Стандартная".
  • Печать — печать графика. Если в настройках программы включена опция "Цветная печать", можно распечатать не черно-белый, а цветной график.
    Это же действие можно выполнить командой меню "Файл — Печать", клавишами-акселераторами Ctrl+P или кнопкой Печать графика панели инструментов "Стандартная".
  • Свойства — вызвать окно настройки параметров графика.
    Это же действие можно выполнить горячей клавишей F8.

Внимание: подменю "Советники", команды "Удалить скрипт", "Список индикаторов" и "Список объектов" активизируются только в случае если на график наложены соответствующие объекты.