Справка по MetaTrader 4
Открытие графиков

Открытие графиков

График отображает динамику цен финансового инструмента во времени. Графики необходимы для проведения технического анализа, работы советников и их тестирования. В терминале одновременно может быть открыто до девяноста девяти графиков.

charts

Новый график можно открыть, выполнив команду меню "Файл — Новый график", меню "Окно — Новое окно" либо нажав кнопку New Chart панели инструментов "Стандартная". При выполнении любого из этих действий появится список доступных финансовых инструментов. Выбрав нужный символ из списка, можно открыть его график. Также новые графики можно открывать из окна "Обзор рынка", удерживая клавишу Ctrl и перетащив элемент списка (финансовый инструмент) из окна в любое место рабочей области терминала или выполнив команду "Окно графика" контекстного меню. Все новые графики открываются с использованием шаблона DEFAULT.TPL, который создается в процессе установки клиентского терминала. Этот шаблон нельзя удалить, но можно изменить.

Исторические данные, на основе которых строятся графики, хранятся на жестком диске. При открытии графика данные загружаются с диска и производится докачка последних недостающих данных с торгового сервера. Если исторические данные по финансовому инструменту отсутствуют на жестком диске, происходит загрузка последних 512 баров истории. Чтобы докачать более ранние данные, необходимо переместить график в требуемую область. После открытия графика в терминал начнет поступать информация о текущих котировках. Таким образом, в режиме реального времени формируется дальнейшая динамика цен. Эта информация автоматически сохраняется в файл истории и используется при повторном открытии этого графика в будущем.

Внимание: в настройках терминала задаются параметры "Макс. баров истории" и "Макс. баров на графике". Эти параметры позволяют контролировать количество отображаемых и сохраняемых на жесткий диск исторических данных.

Оффлайновые графики

Клиентский терминал также позволяет работать с оффлайновыми графиками. Эти графики открываются на основе сохраненных на жесткий диск данных в формате HST. Они не обновляются с сервера. Такие графики оказываются очень полезными для работы с нестандартными инструментам и периодами.

Для открытия нового графика в режиме оффлайн необходимо выполнить команду меню "Файл — Открыть автономно". Затем в появившемся окне следует выбрать финансовый инструмент и нажать кнопку "Открыть". К графику автоматически применяется шаблон OFFLINE.TPL. При этом в заголовке оффлайнового графика добавляется надпись "(offline)".

При тестировании советника создается и используется файл данных формата FXT. Он отличается от обычного графика, но его можно открывать в оффлайне.